Status
Home
Incidents
Help Centre
Delayed deposits
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved. Delayed Payouts from June 1st have been deposited in merchants' bank accounts today, June 5th.
Posted
Jun
05
,
2026
-
21:17
UTC
Monitoring
A temporary delay is currently affecting the scheduled payout for June 1st. Some of our merchants will notice a delay in receiving their funds.
Please accept our apologies for the inconvenience, and keep an eye on our Status Page for further updates.
Posted
Jun
02
,
2026
-
17:43
UTC
This incident affected: Sweden.
×
Subscribe to Incident
Subscribe to updates for
Delayed deposits
via . You'll receive .