Issues with accepting card payments - ES

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Nov 24, 2023 - 10:27 UTC

Investigating

We are currently experiencing difficulties with processing card payments and are working on implementing a fix as soon as possible.

Our merchants will notice that not all card payments will be processed as expected.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Nov 23, 2023 - 20:59 UTC
This incident affected: Spain.