Issues with Taking Card Payments on Android App ( FR, FL, NO, GB, SE, DE, MX )
Incident Report for Zettle Status Page
Resolved
This incident is now resolved. Please update the Zettle GO app to the most recent version.
Posted May 22, 2023 - 15:10 UTC
Update
We are continuing to investigate this issue. Apologies for the inconvenience.
Posted May 16, 2023 - 15:44 UTC
Investigating
We are currently investigating this issue. Merchants may see an error "Something went wrong" when trying to take a card payment, we have noticed that updating the Zettle Go app or deleting and re-installing the app does solve this issue.
Posted May 16, 2023 - 08:42 UTC
This incident affected: UK, Sweden, Norway, Finland, Germany, France, and Mexico.