This has been resolved, and all payouts will be processed and visible before the weekend. This also means that there will no be delay experienced by our merchants.
Posted Mar 27, 2025 - 16:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 27, 2025 - 14:09 UTC
Investigating
There is an ongoing delay for scheduled deposits.
Our merchants will notice a delay in receiving their funds. The payments that should have been credited tomorrow 28th of March will become visible with a delay of one banking day.