Issues accepting payments with MasterCard - Nordics
Incident Report for Zettle Status Page
Resolved
A fix has been successfully implemented and the issue no longer persists. We are deeming this incident as resolved.

Thank you for your patience.

Zettle Team
Posted May 13, 2022 - 14:27 UTC
Update
We continue to investigate the issue. We will post the next update once we have further developments.
Thank you for your patience.
Posted May 13, 2022 - 13:43 UTC
Investigating
We are currently experiencing difficulties accepting payments with MasterCard. We are working to resolve the issue as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.

Thank you for your patience.
Posted May 13, 2022 - 12:56 UTC
This incident affected: Sweden, Norway, Denmark, and Finland.