Issues with Product Library

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 18:27 UTC

Update

We are continuing to investigate this issue.
Posted Apr 02, 2026 - 18:27 UTC

Investigating

We are currently experiencing difficulties with the Product Library and are working on implementing a fix as soon as possible.

Our merchants will notice a delay in searching for products, and creating new products.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Apr 02, 2026 - 14:12 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.