This issue has been resolved. All upcoming payouts will be complete again.
Posted Jul 03, 2025 - 16:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 03, 2025 - 11:17 UTC
Identified
Some merchants may notice that today's payout is lower than expected. This is due to a technical issue, and we're working with the highest priority to ensure that the missing payments are included in the next scheduled payout.
We apologise for the inconvenience and recommend keeping an eye on our Status Page for updates.
Posted Jul 03, 2025 - 11:16 UTC
This incident affected: Denmark, Finland, Germany, France, and Spain.