Issues with Account Registration - MX
Incident Report for Zettle Status Page
Resolved
This incident has been resolved and new merchants are able to register again.
Posted Nov 21, 2022 - 13:35 UTC
Investigating
We are once again experiencing difficulties with automatic account registrations and are currently investigating.

Our merchants will notice they will not be able to register successfully for a new Zettle account. To get onboarded manually, please contact our Support.

Please accept our apologies for the inconvenience.
Posted Nov 21, 2022 - 08:01 UTC
This incident affected: Mexico.