Status
Home
Incidents
Help Centre
Delayed deposits - FI
Incident Report for
Zettle Status Page
Resolved
This incident has been resolved.
Posted
Oct
30
,
2024
-
13:56
UTC
Investigating
There is an ongoing delay on scheduled payouts.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted
Oct
29
,
2024
-
14:24
UTC
This incident affected: Finland.
×
Subscribe to Incident
Subscribe to updates for
Delayed deposits - FI
via . You'll receive .