Issues with accepting card payments & accessing backoffice

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 15:25 UTC

Update

We are continuing to investigate this issue. Thank you for your patience
Posted Mar 24, 2025 - 14:45 UTC

Investigating

We are currently experiencing difficulties with accepting card payments in all markets and are working on implementing a fix as soon as possible. Merchants might also experience issues logging in to the backoffice.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Mar 24, 2025 - 14:02 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.