Issues with app log-in

Incident Report for Zettle Status Page

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 13:05 UTC

Investigating

We are currently investigating an issue where some users are unable to log in the Zettle Go App. Our team is working to identify the cause and resolve it as quickly as possible. Thank you for your patience.
Posted Jul 22, 2025 - 09:20 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.