Status
Home
Incidents
Help Centre
Webshop Update
Incident Report for
Zettle Status Page
Resolved
Maintenence has been completed and our web-shop is back up and running.
Thank you for your patience.
Posted
Sep
26
,
2023
-
08:06
UTC
Investigating
Our webshop is currently undergoing maintenance and will be unavailable for a short time.
We apologise for the inconvenience.
Posted
Sep
26
,
2023
-
07:15
UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.
×
Subscribe to Incident
Subscribe to updates for
Webshop Update
via . You'll receive .