Issues with accepting payments

Incident Report for Zettle Status Page

Resolved

The issue has now been resolved. Our systems are fully operational again, and payments are being processed as expected.

We sincerely apologise for the inconvenience this disruption may have caused.
Posted Aug 27, 2025 - 13:25 UTC

Update

We are continuing to investigate this issue.
Posted Aug 27, 2025 - 13:11 UTC

Investigating

Some merchants are currently experiencing issues with taking payments, our teams are working on this.
Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.

Thank you for your patience.
Posted Aug 27, 2025 - 13:02 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, and Mexico.