Issues with accepting card payments in Mexico
Incident Report for Zettle Status Page
Resolved
This incident has been resolved. Thank you for your patience.
Posted Jul 13, 2024 - 18:42 UTC
Investigating
We are currently experiencing difficulties with accepting card payments in Mexico and are working on implementing a fix as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Jul 13, 2024 - 17:44 UTC
This incident affected: Mexico.