The issue has been resolved and all services are now operating normally.
Posted Apr 29, 2025 - 07:07 UTC
Monitoring
At the moment, due to a power outage affecting some regions in Europe, one of our service locations is impacted. This could result in longer waiting times when reaching out to our Customer Support.
We sincerely apologise for any inconvenience this may cause. In the meantime, please visit our Help Center on www.zettle.com.
Posted Apr 28, 2025 - 12:35 UTC
This incident affected: UK, Netherlands, Germany, and France.