Issues with Registration and Document Upload
Incident Report for Zettle Status Page
Resolved
We have successfully implemented a fix and the issue no longer persists. We are deeming this incident as resolved.

Thank you for your patience.

Zettle Team
Posted Jun 22, 2022 - 06:29 UTC
Update
We continue to investigate the issue. We will post the next update once we have further developments.
Thank you for your patience.
Posted Jun 21, 2022 - 15:00 UTC
Investigating
We are currently experiencing difficulties with Registrations and Document Upload and are working on implementing a fix as soon as possible.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Jun 21, 2022 - 13:12 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, and Italy.