Issues with our Back-office
Incident Report for Zettle Status Page
Resolved
We have successfully implemented a fix and the issue no longer persists. We are deeming this incident as resolved.

Thank you for your patience.

Zettle Team
Posted Apr 30, 2021 - 11:41 UTC
Investigating
We are currently experiencing difficulties with our Back-office and are working on implementing a fix as soon as possible.

Our merchants will notice an error message "We'll be back shortly" when accessing some pages on my.zettle.com.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Apr 30, 2021 - 10:57 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, Italy, Brazil, and Mexico.