Issues with Payments and Receipt Generation ( FI, DE, SE, NL, NO, GB, FR, DK, ES, IT )
Incident Report for Zettle Status Page
Resolved
This incident has been resolved. Please accept our apologies for the inconvenience and thank you for your patience.
Posted Jul 01, 2022 - 15:22 UTC
Update
We continue to work on the ongoing issues we are experiencing. Please rest assured that this is our top priority and we are working urgently to reach a resolution as quickly as possible.
Please accept our apologies for the disruption. We will follow-up with more updates soon.
Posted Jul 01, 2022 - 10:16 UTC
Update
We are continuing to investigate this issue.
Posted Jul 01, 2022 - 09:07 UTC
Investigating
We are currently experiencing difficulties with accepting payments and generating receipts and are working on implementing a fix as soon as possible.

Our merchants will notice that they might not be able to take payments and/or receipts will not be generated.

Please accept our apologies for the inconvenience and keep an eye on our Status Page for further updates.
Posted Jul 01, 2022 - 08:13 UTC
This incident affected: UK, Sweden, Norway, Denmark, Finland, Netherlands, Germany, France, Spain, and Italy.